Desain Jaringan dengan Kombinasi Konfigurasi Routing OSPF dan BGP

3 min read


Assalamualaikum teman-teman….

Setelah kita belajar tentang routing  OSPF di post saya sebelumnya , materi yang cocok untuk kita pelajari selanjutnya adalah Mengkombinasikan routing OSPF dan BGP ,materi ini saya dapat dari pemateri Diklat Guru IT Bisa yang dilaksanakan empat hari berturut-turut ini.

1.Latar Belakang

Pada dasarnya Bila kita menggabungkan dua konfigurasi tersebut, hal yang kita dapat adalah bahwa kedua routing tersebut dapat saling megurangi kedua kekurangan .Seperti OSPF (Open Shortest Path First ) merupakan sebuah routing protokol berjenis IGP (interior gateway routing protocol) yang hanya dapat bekerja dalam jaringan internal suatu ogranisasi atau perusahaan. Jaringan internal maksudnya adalah jaringan di mana masih memiliki hak untuk menggunakan, mengatur, dan memodifikasinya. Atau dengan kata lain,  masih memiliki hak administrasi terhadap jaringan tersebut. Jika sudah tidak memiliki hak untuk menggunakan dan mengaturnya, maka jaringan tersebut dapat dikategorikan sebagai jaringan eksternal.Oleh karena itu saya akan bereksperimen untuk menambahkan routing BGP dan mengembangkannya pada postingan kali ini.Tapi ngomong-ngomong apa sih BGP itu?????

2.Pengertian

BGP digunakan untuk pertukaran informasi routing untuk Internet dan merupakan protokol yang 
digunakan antar penyedia layanan Internet (ISP). Pelanggan jaringan, seperti perguruan tinggi dan perusahaan, biasanya menggunakan sebuah Interior Gateway Protocol (IGP) seperti RIP atau OSPF untuk pertukaran informasi routing dalam jaringan mereka. Pelanggan menyambung ke ISP, dan ISP menggunakan BGP untuk bertukar pelanggan dan rute ISP . Ketika BGP digunakan antar Autonom System (AS), protokol ini disebut sebagai External BGP (EBGP). Jika penyedia layanan menggunakan BGP untuk bertukar rute dalam suatu AS, maka protokol disebut sebagai Interior BGP (IBGP)

3.Maksud dan Tujuan 

Untuk Merubah Jaringan Internal agar dapat menjadi Jaringan umum atau public

4.Alat yang dipersiapkan

Cisco Packet Tracer yang sudah diinstall di laptop atau komputer

5.Langkah Langkah

Pada tahap ini kita konsentrasi dulu pada langkah konfigurasi ,dan cermati setiap langkahnya karena kalau tidak,jika ada kesalahan maka kita juga harus teliti untuk mencari sumber kesalahannya.oke deeeh.Langsung saja cermati dulu gambar dibawah..





 Gambar samping merupakan ilustrasi dari wilayah provinsi Jawa Timur yang saya beri disain jaringan menggunakan konfigurasi routing OSPF dan BGP.Pada gambar tersebut terdapat 10 router yaitu yang saya beri nama R1 sampai R10.Kita harus konfigurasi OSPF terlebih dahulu yang berada pada R3 sampai R10,untuk R1 dan R2 digunakan dalam konfigurasi BGP.
Untuk yang kabel warna merah yaitu kabel Serial yang menghubungkan R1 dan R2 sebagai tempat konfigurasi BGP


Pertama Kita kasih alamat loop sama ip nya dulu.Kerjakan sesuai Urutan Dibawah ya….
_________________________________________________________________________________
R1


Router>en
Router#conf t
Router(config)#interface loopback 0
Router(config-if)#ip address 1.1.1.1 255.255.255.255
Router(config-if)#ex
Router(config)#interface fa0/0
Router(config-if)#ip address 192.168.1.1 255.255.255.0
Router(config-if)#no sh
Router(config-if)#ex
Router(config)#interface fa0/1
Router(config-if)#ip address 192.168.5.1 255.255.255.0
Router(config-if)#no sh
Router(config-if)#ex
Router(config)#interface ethernet0/0/0
Router(config-if)#ip address 192.168.3.1 255.255.255.0
Router(config-if)#no sh
Router(config-if)#ex
Router(config)#interface serial0/1/0
Router(config-if)#ip address 172.168.1.1 255.255.255.0
Router(config-if)#no sh
Router(config-if)#ex
___________________________________________________________________________________
R2

Router>en
Router#conf t
Router(config)#interface loopback 0
Router(config-if)#ip address 2.2.2.2 255.255.255.255
Router(config-if)#ex
Router(config)#interface fa0/0
Router(config-if)#ip address 192.168.2.1 255.255.255.0
Router(config-if)#no sh
Router(config-if)#ex
Router(config)#interface fa0/1
Router(config-if)#ip address 192.168.6.1 255.255.255.0
Router(config-if)#no sh
Router(config-if)#ex
Router(config)#interface ethernet0/0/0
Router(config-if)#ip address 192.168.4.1 255.255.255.0
Router(config-if)#no sh
Router(config-if)#ex
Router(config)#interface serial0/1/0
Router(config-if)#ip address 172.168.1.2 255.255.255.0
Router(config-if)#no sh
Router(config-if)#ex

___________________________________________________________________________________
R3

Router>en
Router#conf t
Router(config)#interface loopback 0
Router(config-if)#ip address 3.3.3.3 255.255.255.255
Router(config-if)#ex
Router(config)#interface fa0/0
Router(config-if)#ip address 192.168.1.2 255.255.255.0
Router(config-if)#no sh
Router(config-if)#ex

___________________________________________________________________________________
R4
Router>en
Router#conf t
Router(config)#interface loopback 0
Router(config-if)#ip address 4.4.4.4 255.255.255.255
Router(config-if)#ex
Router(config)#interface fa0/0
Router(config-if)#ip address 192.168.2.2 255.255.255.0
Router(config-if)#no sh
Router(config-if)#ex
___________________________________________________________________________________
R5

Router>en
Router#conf t
Router(config)#interface loopback 0
Router(config-if)#ip address 5.5.5.5 255.255.255.255
Router(config-if)#ex
Router(config)#interface fa0/0
Router(config-if)#ip address 192.168.3.2 255.255.255.0
Router(config-if)#no sh
Router(config-if)#ex

___________________________________________________________________________________
R6

Router>en
Router#conf t
Router(config)#interface loopback 0
Router(config-if)#ip address 6.6.6.6 255.255.255.255
Router(config-if)#ex
Router(config)#interface fa0/0
Router(config-if)#ip address 192.168.4.2 255.255.255.0
Router(config-if)#no sh
Router(config-if)#ex

____________________________________________________________________________________
R7

Router>en
Router#conf t
Router(config)#interface loopback 0
Router(config-if)#ip address 7.7.7.7 255.255.255.255
Router(config-if)#ex
Router(config)#interface fa0/0
Router(config-if)#ip address 192.168.7.1 255.255.255.0
Router(config-if)#no sh
Router(config-if)#ex
Router(config)#interface fa0/1
Router(config-if)#ip address 192.168.5.2 255.255.255.0
Router(config-if)#no sh
Router(config-if)#ex
____________________________________________________________________________________
R8

Router>en
Router#conf t
Router(config)#interface loopback 0
Router(config-if)#ip address 8.8.8.8 255.255.255.255
Router(config-if)#ex
Router(config)#interface fa0/0
Router(config-if)#ip address 192.168.8.1 255.255.255.0
Router(config-if)#no sh
Router(config-if)#ex
Router(config)#interface fa0/1
Router(config-if)#ip address 192.168.6.2 255.255.255.0
Router(config-if)#no sh
Router(config-if)#ex
____________________________________________________________________________________
R9

Router>en
Router#conf t
Router(config)#interface loopback 0
Router(config-if)#ip address 9.9.9.9 255.255.255.255
Router(config-if)#ex
Router(config)#interface fa0/0
Router(config-if)#ip address 192.168.7.2 255.255.255.0
Router(config-if)#no sh
Router(config-if)#ex
____________________________________________________________________________________
R10

Router>en
Router#conf t
Router(confconfigig)#interface loopback 0
Router(-if)#ip address 10.10.10.10 255.255.255.255
Router(config-if)#ex
Router(config)#interface fa0/0
Router(config-if)#ip address 192.168.8.2 255.255.255.0
Router(config-if)#no sh
Router(config-if)#ex
___________________________________________________________________________________
Setelah itu konfigurasi Routing OSPF

R3
Router(config)#router ospf 10
Router(config-router)#network 3.3.3.3 0.0.0.0 area 0
Router(config-router)#network 192.168.1.0 0.0.0.255 area 0
Router(config-router)#ex

R4
Router(config)#router ospf 10
Router(config-router)#network 4.4.4.4 0.0.0.0 area 0
Router(config-router)#network 192.168.2.0 0.0.0.255 area 0
Router(config-router)#ex

R5
Router(config)#router ospf 10
Router(config-router)#network 5.5.5.5 0.0.0.0 area 0
Router(config-router)#network 192.168.3.0 0.0.0.255 area 0
Router(config-router)#ex

R6
Router(config)#router ospf 10
Router(config-router)#network 6.6.6.6 0.0.0.0 area 0
Router(config-router)#network 192.168.4.0 0.0.0.255 area 0
Router(config-router)#ex

R9
Router(config)#router ospf 10
Router(config-router)#network 9.9.9.9 0.0.0.0 area 0
Router(config-router)#network 192.168.7.0 0.0.0.255 area 0
Router(config-router)#ex

R10
Router(config)#router ospf 10
Router(config-router)#network 10.10.10.10 0.0.0.0 area 0
Router(config-router)#network 192.168.8.0 0.0.0.255 area 0
Router(config-router)#ex

R7
Router(config)#router ospf 10
Router(config-router)#network 7.7.7.7 0.0.0.0 area 0
Router(config-router)#network 192.168.7.0 0.0.0.255 area 0
Router(config-router)#network 192.168.5.0 0.0.0.255 area 0
Router(config-router)#ex

R8
Router(config)#router ospf 10
Router(config-router)#network 8.8.8.8 0.0.0.0 area 0
Router(config-router)#network 192.168.8.0 0.0.0.255 area 0
Router(config-router)#network 192.168.6.0 0.0.0.255 area 0
Router(config-router)#ex


Lalu yang terakhir adalah Konfigurasi  Routing BGP
___________________________________________________________________________________
R1

Router(config)#router bgp 65100
Router(config-router)#redistribute ospf 10
Router(config-router)#neighbor 172.168.1.2 remote-as 65200
Router(config-router)#network 172.168.1.0 mask 255.255.255.0
Router(config-router)#ex
Router(config)#router ospf 10
Router(config-router)#redistribute bgp 65100 subnets tag 65100
Router(config-router)#network 1.1.1.1 0.0.0.0 area 0
Router(config-router)#network 192.168.1.0 0.0.0.255 area 0
Router(config-router)#network 192.168.3.0 0.0.0.255 area 0
Router(config-router)#network 192.168.5.0 0.0.0.255 area 0
Router(config-router)#network 192.168.7.0 0.0.0.255 area 0
Router(config-router)#ex

___________________________________________________________________________________
R2

Router(config)#router bgp 65100
Router(config-router)#redistribute ospf 10
Router(config-router)#neighbor 172.168.1.2 remote-as 65200
Router(config-router)#network 172.168.1.0 mask 255.255.255.0
Router(config-router)#ex
Router(config)#router ospf 10
Router(config-router)#redistribute bgp 65100 subnets tag 65100
Router(config-router)#network 1.1.1.1 0.0.0.0 area 0
Router(config-router)#network 192.168.2.0 0.0.0.255 area 0
Router(config-router)#network 192.168.4.0 0.0.0.255 area 0
Router(config-router)#network 192.168.6.0 0.0.0.255 area 0
Router(config-router)#network 192.168.8.0 0.0.0.255 area 0
Router(config-router)#ex


6.Kesimpulan dan Hasil

Jadi Mengkonfigurasi OSPF dan BGP itu sangat mudah jika kita teliti dalam mengerjakannya,jika kita tidak teliti,kesalahan sati digit saja akan menimbulkan kesalahan yang fatal.

7.Referensi

  • http://herliandiserli.blogspot.co.id/2012/04/kelebihan-dan-kekurangan-rip-igrp-ospf.html

Aljabar Boolean

sibro
1 min read

Yang Dimaksud Swapping

sibro
2 min read

Tentang Memori Internal

sibro
3 min read

Leave a Reply